Freesco, NND, CDN, EOS

http://www.freesco.pl
Dzisiaj jest niedziela, 25 czerwca 2017, 00:36

Strefa czasowa UTC+2godz.




Nowy temat Odpowiedz w temacie  [ Posty: 33 ]  Przejdź na stronę 1, 2  Następna
Autor Wiadomość
Post: piątek, 4 czerwca 2010, 10:49 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Zrobiłem wszystko wg opisu na stronie
pliki konfiguracyjne poniżej:
http://188.122.20.155/admin/

założony użytkownik: info@samotwor.pl

Nie mogę się w żaden sposób zalogować przez outlooka żąda hasła po wprowadzeniu nadal żąda.
"Wystąpił problem przy logowaniu się do Twojego serwera pocztowego. Twoje hasło zostało odrzucone. Konto: 'samotwor.pl', Serwer: 'www.samotwor.pl', Protokół: POP3, Odpowiedź serwera: '-ERR Authentication failed.', Port: 110, Zabezpieczenie (SSL): Nie, Błąd serwera: 0x800CCC90, Numer błędu: 0x800CCC92"

To nie jest wina konfiguracji oe.
Problem leży gdzieś w połączniu tpop3d z bazą sql.
Próba połączenia z serwerem poczty przez telnet daje :"authentication failed" przy próbie wpisania hasła.

telnet samotwo.pl 110
user info
pass hasło
i tu mamy błąd


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: piątek, 4 czerwca 2010, 12:39 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Ma być user@domena.pl - to jest prawidłowa nazwa użytkownika, taka sama jak adres mail.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: piątek, 4 czerwca 2010, 22:34 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
telnet samotwor.pl 110
user info@samotwor.pl
pass hasło
i tu też mamy błąd "-ERR Autentication failed"


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: piątek, 4 czerwca 2010, 22:40 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
A w logi zaglądałeś? W pliku konfiguracyjnym prawidłowego usera i hasło do bazy podałeś?

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: piątek, 4 czerwca 2010, 22:55 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Przecież podałem link do plików konfiguracyjnych razem z plikiem konfiguracyjnym bazy danych.

Wysyłać pocztę mogę. Ale nie mogę odbierać.


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 5 czerwca 2010, 00:23 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
: [/] [] ()
May 25 09:50:39 serwer tpop3d[14420]: get_mysql_server: can't find any working MySQL server; giving up
May 25 09:50:39 serwer tpop3d[14420]: auth_mysql_init: aborting
May 25 09:50:39 serwer tpop3d[14420]: failed to initialise mysql authentication driver

: [/] [] ()
2010-05-25 09:57:00 H=eob196.internetdsl.tpnet.pl (betard12315643) [83.15.213.196] F=<info@samotwor.pl> rejected RCPT <info@samotwor.pl>: Najpierw sie zaloguj - Authenticate first

Według mnie masz problem zarówno z eximem, jak i z tpop3d. Pierwszy log wskazuje na problem z mysql? Działa?
Być może powinieneś zmienić hasło na takie składające się z czystych znaków ascii, a już w żadnym wypadku nie używąć # na początku.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 5 czerwca 2010, 00:51 
Offline
PGF

Rejestracja: piątek, 25 lutego 2005, 18:22
Posty: 1430
Lokalizacja: Elbląg
Maciek, fragment logów exima, który przytoczyłeś, akurat świadczy o próbie nie autoryzowanego wykorzystania serwera przez jakiegoś spamera, natomiast inne fragmenty świadczą, że mysql działa:
Cytuj:
2010-05-25 09:00:16 1OGo7c-0002sP-BM <= root@mirkow.eu U=root P=local S=6491
2010-05-25 09:00:17 1OGo7c-0002sP-BM => costam <root@mirkow.eu> R=mysql_localuser T=mysql_delivery

Problem jest z tpopem, który nie może połączyć się z serwerem mysql, za cholerę nie wiem dlaczego - dane do połączenia w konfigu są wpisane prawidłowo...

_________________
F33/F07,F11,F13,F17
ObrazekObrazek


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 5 czerwca 2010, 12:25 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Napisałem też o drugim możliwym powodzie - hasło.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 5 czerwca 2010, 22:59 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Zmieniłem hasło do bazy, ale nic to nie dało.

http://188.122.20.155/admin/ - aktualne ustawienia i logi


Nadal zachowuje się identycznie. Mogę wysyłać, ale przy próbie odbioru

Cytuj:
Wystąpił problem przy logowaniu się do Twojego serwera pocztowego. Twoje hasło zostało odrzucone. Konto: 'mirkow.eu', Serwer: 'mirkow.eu', Protokół: POP3, Odpowiedź serwera: '-ERR Authentication failed.', Port: 110, Zabezpieczenie (SSL): Nie, Błąd serwera: 0x800CCC90, Numer błędu: 0x800CCC92


Zastanawia mnie ta informacja:
Cytuj:
Jun 5 22:45:09 serwer tpop3d[8664]: get_mysql_server: can't find any working MySQL server; giving up
Jun 5 22:45:09 serwer tpop3d[8664]: auth_mysql_init: aborting
Jun 5 22:45:09 serwer tpop3d[8664]: failed to initialise mysql authentication driver


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 00:46 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Zacznijmy od tego:
: [/] [] ()
Mogę wysyłać, ale przy próbie odbioru

Wysyłanie to exim, odbieranie tpop3d - jedno z drugim nie ma nic wspólnego.
Jesteś pewny, że masz tpop3d-sql? Czy w /etc/hosts jest 127.0.0.1 localhost?

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 01:21 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Maciek pisze:
Jesteś pewny, że masz tpop3d-sql? Czy w /etc/hosts jest 127.0.0.1 localhost?


1. 100% tpop3d-sql
2. nie, nie mam tego wpisu. Czy mam go wprowadzić?


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 10:41 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Tak, to może być to. Tpop3d szuka mysql na localhoście.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 12:58 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Nie, nie pomogło
Cytuj:
Wystąpił problem przy logowaniu się do Twojego serwera pocztowego. Twoje hasło zostało odrzucone. Konto: 'mirkow.eu', Serwer: 'mirkow.eu', Protokół: POP3, Odpowiedź serwera: '-ERR Authentication failed.', Port: 110, Zabezpieczenie (SSL): Nie, Błąd serwera: 0x800CCC90, Numer błędu: 0x800CCC92


Cytuj:
Jun 6 12:43:12 serwer tpop3d[8664]: net_loop: terminating on signal 15
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: gethostbyaddr(0.0.0.0): cannot resolve name
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: 0.0.0.0:110: cannot obtain domain suffix for this address
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: 0.0.0.0:110: using fallback domain suffix `serwer'
Jun 6 12:43:14 serwer tpop3d[9645]: parse_listeners: listening on address 0.0.0.0:110; TLS mode STLS
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: gethostbyaddr(0.0.0.0): cannot resolve name
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: 0.0.0.0:995: cannot obtain domain suffix for this address
Jun 6 12:43:14 serwer tpop3d[9645]: listener_new: 0.0.0.0:995: using fallback domain suffix `serwer'
Jun 6 12:43:14 serwer tpop3d[9645]: parse_listeners: listening on address 0.0.0.0:995; TLS mode immediate
Jun 6 12:43:14 serwer tpop3d[9645]: get_mysql_server: server localhost: Access denied for user 'poczta'@'localhost' (using password: YES)
Jun 6 12:43:14 serwer tpop3d[9645]: get_mysql_server: can't find any working MySQL server; giving up
Jun 6 12:43:14 serwer tpop3d[9645]: auth_mysql_init: aborting


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 20:35 
Offline
PGF

Rejestracja: piątek, 25 lutego 2005, 18:22
Posty: 1430
Lokalizacja: Elbląg
idub pisze:
Cytuj:
Jun 6 12:43:14 serwer tpop3d[9645]: get_mysql_server: server localhost: Access denied for user 'poczta'@'localhost' (using password: YES)

A jednak jest postęp, bo zdaje się, że przedtem tpop3 w ogóle się nie łączył z serwerem mysql, teraz się łączy, ale nie dostaje dostępu, więc cudów nie ma, w tpop3d.conf masz źle wpisaną bazę, usera albo hasło..

-- EDIT --
Qrwa, jest źle wpisane :!: :evil: popatrz dobrze :P

_________________
F33/F07,F11,F13,F17
ObrazekObrazek


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 22:54 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Wniosek, brak localhosta.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 23:37 
Offline
PGF

Rejestracja: piątek, 25 lutego 2005, 18:22
Posty: 1430
Lokalizacja: Elbląg
Maciek pisze:
Wniosek, brak localhosta.
Pewnie tak, tylko eximowi jakoś to nie przeszkadzało...

_________________
F33/F07,F11,F13,F17
ObrazekObrazek


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 6 czerwca 2010, 23:44 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
Exim chyba localhosta ma w konfigu własnym, a tpop3d nie.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: poniedziałek, 7 czerwca 2010, 14:03 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Cytuj:
-- EDIT --
Qrwa, jest źle wpisane :!: :evil: popatrz dobrze :P


Tu Masz rację literka wsiąkła.
...

Po zmianie podczas logowania:
Cytuj:
Twój serwer nieoczekiwanie zakończył połączenie. Mogło być to spowodowane: nieprawidłową konfiguracją serwera, problemami z siecią lub długim okresem nieaktywności. Konto: 'mirkow.eu', Serwer: 'mirkow.eu', Protokół: POP3, Port: 110, Zabezpieczenie (SSL): Nie, Numer błędu: 0x800CCC0F


no i błędy:
Cytuj:
Jun 7 13:53:55 serwer tpop3d[2208]: net_loop: terminating on signal 15
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: gethostbyaddr(0.0.0.0): cannot resolve name
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: 0.0.0.0:110: cannot obtain domain suffix for this address
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: 0.0.0.0:110: using fallback domain suffix `serwer'
Jun 7 13:53:57 serwer tpop3d[22763]: parse_listeners: listening on address 0.0.0.0:110; TLS mode STLS
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: gethostbyaddr(0.0.0.0): cannot resolve name
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: 0.0.0.0:995: cannot obtain domain suffix for this address
Jun 7 13:53:57 serwer tpop3d[22763]: listener_new: 0.0.0.0:995: using fallback domain suffix `serwer'
Jun 7 13:53:57 serwer tpop3d[22763]: parse_listeners: listening on address 0.0.0.0:995; TLS mode immediate
Jun 7 13:53:58 serwer tpop3d[22763]: get_mysql_server: now using server localhost
Jun 7 13:53:58 serwer tpop3d[22763]: 2 authentication drivers successfully loaded
Jun 7 13:53:58 serwer tpop3d[22763]: net_loop: tpop3d version 1.5.3 successfully started
Jun 7 13:54:21 serwer tpop3d[22763]: listeners_post_select: client [7]83.12.67.150/serwer: connected to local address 188.122.20.155:110
Jun 7 13:54:22 serwer tpop3d[22763]: authcontext_new_user_pass: began session for `info@mirkow.eu' with mysql; uid 12, gid 12
Jun 7 13:54:22 serwer tpop3d[22763]: fork_child: [7]info@mirkow.eu(83.12.67.150): began session for `info@mirkow.eu' with mysql; child PID is 22773
Jun 7 13:54:22 serwer tpop3d[22773]: quit: signal 11 post_fork = 1
Jun 7 13:54:22 serwer tpop3d[22763]: net_loop: child process 22773 killed by signal 11 (shouldn't happen)



/etc/hosts jest 127.0.0.1 localhost dopisane na samym końcu


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: poniedziałek, 7 czerwca 2010, 17:42 
Offline
Honorowy Admin

Rejestracja: piątek, 5 lipca 2002, 17:30
Posty: 7798
Lokalizacja: Słupsk
: [/] [] ()
Jun 7 13:54:22 serwer tpop3d[22763]: authcontext_new_user_pass: began session for `info@mirkow.eu' with mysql; uid 12, gid 12
Jun 7 13:54:22 serwer tpop3d[22763]: fork_child: [7]info@mirkow.eu(83.12.67.150): began session for `info@mirkow.eu' with mysql; child PID is 22773

Tu jest wpis świadczący, ze po stronie serwera jest OK.
Wypróbuj Thunderbirda. OE jest to ...
Musisz ustawić korzystanie z SSL i w przypadku OE pobrać certyfikat na dysk i go zainstalowac.

_________________
Obrazek Belfer.one.PL
Obrazek Audio Cafe


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: poniedziałek, 7 czerwca 2010, 23:29 
Offline
Użytkownik

Rejestracja: wtorek, 21 czerwca 2005, 18:51
Posty: 132
Cytuj:
Wypróbuj Thunderbirda. OE jest to ...
Musisz ustawić korzystanie z SSL i w przypadku OE pobrać certyfikat na dysk i go zainstalowac.


Thunderbird także nie może odebrać poczty.

Cytuj:
Twój serwer nieoczekiwanie zakończył połączenie. Mogło być to spowodowane: nieprawidłową konfiguracją serwera, problemami z siecią lub długim okresem nieaktywności. Konto: 'mirkow.eu', Serwer: 'mirkow.eu', Protokół: POP3, Port: 110, Zabezpieczenie (SSL): Nie, Numer błędu: 0x800CCC0F
odpowiedź oe

Cytuj:
Jun 7 22:37:38 serwer tpop3d[16124]: quit: signal 11 post_fork = 1
Jun 7 22:37:38 serwer tpop3d[22763]: net_loop: child process 16124 killed by signal 11 (shouldn't happen)
errors


Na górę
 Wyświetl profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 33 ]  Przejdź na stronę 1, 2  Następna

Strefa czasowa UTC+2godz.


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
cron
Technologię dostarcza phpBB® Forum Software © phpBB Group
Hosting: Compus-Net
RobertKonik.pl