Freesco, NND, CDN, EOS

http://www.freesco.pl
Dzisiaj jest wtorek, 24 października 2017, 13:06

Strefa czasowa UTC+2godz.




Nowy temat Odpowiedz w temacie  [ Posty: 13 ] 
Autor Wiadomość
Post: czwartek, 25 marca 2004, 19:00 
Offline
MODERATOR

Rejestracja: poniedziałek, 27 stycznia 2003, 23:39
Posty: 3065
Lokalizacja: Kraków/Częstochowa
Powstały poprawki do Freesco 0.3.2 zalecam ich zainstalowanie.
Opis i linki do poprawek znajdują się na forum angielskim:
http://forums.freesco.org/support/index.php?act=ST&f=1&t=7839&hl=&s=5ac04c42ba2e46a9ceb4593498015087


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: czwartek, 25 marca 2004, 19:16 
Właśnie też je przeglądam. Tylko może ktoś by przetłumaczył po polskiemu. Bo Ja np., nie wiem co autor miał na myśli :twisted: pisząc w poprawce:

Cytuj:
CODE

str()

#anywhere in the str() section will work.
umask 22 /etc/dhcpd.leases

;;


Czy mam tą liniijkę wstawić do pliku /rc/rc_dhcpd - bo jej tam nie znalazłem, czy co :?:


Na górę
  
 
 Tytuł:
Post: czwartek, 25 marca 2004, 22:23 
Offline
MODERATOR

Rejestracja: poniedziałek, 27 stycznia 2003, 23:39
Posty: 3065
Lokalizacja: Kraków/Częstochowa
autor miał na myśli że trzeba to dopisać w sekcji str()


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: czwartek, 25 marca 2004, 23:07 
Hmm.
Nie polecam tego dopisywać. W mojej sieci numery ip są przypisywane klientom z serwera, po wpisaniu tej linijki i zrestartowaniu uslug dhcp i dns mogłem o tym później tylko pomarzyć :lol: . W każdym razie już po restarcie dhcpd wyskoczył błąd: linia 4 w pliku etc/dhcpd.leases. Więc z tą poprawką to jakiś przekręt :? .


Na górę
  
 
 Tytuł:
Post: sobota, 27 marca 2004, 00:13 
Offline
MODERATOR

Rejestracja: poniedziałek, 27 stycznia 2003, 23:39
Posty: 3065
Lokalizacja: Kraków/Częstochowa
Piotrek pisze:
Hmm.
Nie polecam tego dopisywać. W mojej sieci numery ip są przypisywane klientom z serwera, po wpisaniu tej linijki i zrestartowaniu uslug dhcp i dns mogłem o tym później tylko pomarzyć :lol: . W każdym razie już po restarcie dhcpd wyskoczył błąd: linia 4 w pliku etc/dhcpd.leases. Więc z tą poprawką to jakiś przekręt :? .


to nie żaden przekręt :!:
poprostu coś popsułeś w pliku /etc/dhcpd.leases, to polecenie nic w nim nie zmienia, radzę usunąć wszystko z tego pliku, ale przedtem zrobić jego kopie


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 27 marca 2004, 16:00 
Nie wiem czy moge kontynuować ten topic tutaj, ale jeśli nie - to możesz go podzielić i wrzucić jako nowy wątek :oops: . Pomyliłem nazwy plików błąd wywala nie w etc/dhcpd.leases tylko w w etc/dhcpd.conf - sorry za pomyłkę.

W każdym razie "tą poprawkę" wklejam w miejscu:
Cytuj:
str() {
[ "$ENADHCP" = n -o "`fn2`" ] && return
set -- `echo $LIZTIME | sed s/,/\ /g`
cat >/etc/dhcpd.conf <<-EOF
option domain-name "$DOMAIN";
default-lease-time ${1:-345600};
max-lease-time ${2:-345600};
umask 22 /etc/dhcpd.leases

może to nie w tym miejscu. Po restarcie rc_dhcpd wywala taki komunikat:
Cytuj:
[Linux] rc_dhcpd restart
Starting dhcpd... /etc/dhcpd.conf line 4: expecting a parameter or declaration.
umask
^
Configuration file errors encountered -- exiting
exiting.
Done eth1
[Linux]


Po tym jeszcze robię: rc_dns restart, sync, sync.
Może powinienem zrestartować wogóle Freesco :idea: .


Na górę
  
 
 Tytuł:
Post: sobota, 27 marca 2004, 16:20 
Offline
MODERATOR

Rejestracja: poniedziałek, 27 stycznia 2003, 23:39
Posty: 3065
Lokalizacja: Kraków/Częstochowa
Piotrek pisze:
Nie wiem czy moge kontynuować ten topic tutaj, ale jeśli nie - to możesz go podzielić i wrzucić jako nowy wątek :oops:

no chyba nie powinniśmy, sam nie wiem :) może jakiś moderator się nami zajmie ;P

Piotrek pisze:
[Linux] rc_dhcpd restart
Starting dhcpd... /etc/dhcpd.conf line 4: expecting a parameter or declaration.
umask
^
Configuration file errors encountered -- exiting
exiting.
Done eth1
[Linux]

pisze przecież jak byk że jest błąd w 4 linii dhcpd.conf więc zajżyj i sprawdź co skopałeś 8)


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 27 marca 2004, 17:18 
Na pewno nie mogłem tego skopać. Bez tej poprawki system nie pokazuje błędów w pliku dhcpd.conf. Odpala się bez problemu.

Błąd który pokazuje w pliku etc/dhcpd.conf - wskazuje właśnie na dopisany fragment, czyli umask 22 /etc/dhcpd.leases, który pojawia się w tym miejscu po dopisaniu go do pliku /mnt/bootdev/router/rc/rc_dhcpd - sprawdziłem to.
Próbowałem wpisywać go z dwoma spacjami pomiędzy umask i 22, 22 i etc, ale to samo.


Na górę
  
 
 Tytuł:
Post: sobota, 27 marca 2004, 17:43 
Offline
PGF

Rejestracja: niedziela, 14 lipca 2002, 14:33
Posty: 3234
Lokalizacja: Radziejów
Ale sobie miejsce wybrales do wklejenia tej poprawki. Gratuluje.

prawdopdobnie po linii:
#anywhere in the str() section will work.


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: sobota, 27 marca 2004, 18:04 
No dobra. Inaczej zaczniemy. To jest mój plik rc_dhcpd (z deka długi ;)):
Cytuj:
#!/bin/sh
#
# Start/stop DHCP service

. /etc/system.cfg
. /etc/colors
. /etc/chat.pwd
. /etc/live.cfg


fn2() { ps | sed -n '/ dhcpd/P'; }
stp() {
[ "`fn2`" ] || return
echo -n "Stopping dhcpd... "
killall dhcpd -15
sleep 2
killall dhcpd
=
}
fn1() {
eval a='$'INTNAME$1 b='$'BRDCAST$1 c='$'NETWORK$1
eval d='$'NETMASK$1 e='$'IPRANGE$1 f='$'IPADDR$1
[ "$a" -a "$b" -a "$c" -a "$d" -a "$e" -a "$f" ] || return
[ "`ifconfig $a 2>/dev/null | sed -n /UP/P`" ] || return
INT="$INT $a"
cat >>/etc/dhcpd.conf <<-EOF
subnet $c netmask $d {
range $e;
option subnet-mask $d;
option broadcast-address $b;
option routers $f;
EOF
[ "$ENADNS" = n ] && f="$DNSADDR"
[ "$DNSADDR1" ] && f="$f,$DNSADDR1"
echo "option domain-name-servers $f;" >>/etc/dhcpd.conf
echo "}" >>/etc/dhcpd.conf
}
str() {
[ "$ENADHCP" = n -o "`fn2`" ] && return
set -- `echo $LIZTIME | sed s/,/\ /g`
cat >/etc/dhcpd.conf <<-EOF
option domain-name "$DOMAIN";
default-lease-time ${1:-345600};
max-lease-time ${2:-345600};
umask 22 /etc/dhcpd.leases #tutaj wpakowałem tą linijkę bez tego komentarza oczywiście

EOF
[ "$WINSADDR" ] && cat >>/etc/dhcpd.conf <<-EOF
option netbios-name-servers $WINSADDR;
option netbios-dd-server $WINSADDR;
option netbios-node-type 8;

EOF
[ "$USEDHCP0" = n ] && fn1 0
for i in 1 2 3 4 5 6 7 8 9; do fn1 $i; done
cat /boot/etc/dhcp.cfg 2>/dev/null | sed '/^#.*$/d' >>/etc/dhcpd.conf
[ "$INT" ] || return 2
INT=`echo $INT | sed s/:.//g`
[ "$BOOTMOD" = debug -o "$LOGDHCP" = y ] && DBG="-d"
echo -n "Starting dhcpd... $CR"
dhcpd -q $INT
chmod 644 /etc/dhcpd.leases
= $? "Done $CC $INT"
}

case "$1" in
start) str;;
stop) stp;;
restart|newip) stp;str;;
status) if [ "`fn2`" ]
then echo "Running dhcpd:"; fn2
else echo No running dhcpd
fi;;
esac


Po wprowadzeniu tej zmiany, robię rc_dhcpd restart - wtedy wywala błąd, który opisałem już wczśniej.
Gdzie waszym zdaniem ma znaleźć się linijka z poprawką :?:


Na górę
  
 
 Tytuł:
Post: sobota, 27 marca 2004, 18:50 
Offline
PGF

Rejestracja: niedziela, 14 lipca 2002, 14:33
Posty: 3234
Lokalizacja: Radziejów
str() {
TU
[ "$ENADHCP" = n -o "`fn2`" ] && return
TU
set -- `echo $LIZTIME | sed s/,/\ /g`
TU
cat >/etc/dhcpd.conf <<-EOF
option domain-name "$DOMAIN";
default-lease-time ${1:-345600};
max-lease-time ${2:-345600};
.


Na górę
 Wyświetl profil  
 
 Tytuł:
Post: niedziela, 28 marca 2004, 16:54 
Teraz działa :) . Ale Lightning opis fajny zrobił, nie ma co :? .


Na górę
  
 
 Tytuł:
Post: niedziela, 28 marca 2004, 20:14 
Offline
PGF

Rejestracja: niedziela, 14 lipca 2002, 14:33
Posty: 3234
Lokalizacja: Radziejów
Na pewnym poziomie wiedzy, nie zwraca sie uwagi na szczegóły.
Jak mawiał pewien skrzypek:
-To jest elementarne Watsonie


Na górę
 Wyświetl profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 13 ] 

Strefa czasowa UTC+2godz.


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
cron
Technologię dostarcza phpBB® Forum Software © phpBB Group
Hosting: Compus-Net
RobertKonik.pl